Browse Source

Suppression warnings et compatibilié spip 4.1

master
pierrox 6 months ago
parent
commit
d56f20df78
  1. 2
      paquet.xml
  2. 6
      partenaires_pipelines.php

2
paquet.xml

@ -3,7 +3,7 @@
categorie="divers"
version="1.7.0"
etat="dev"
compatibilite="[3.0.5;3.2.*]"
compatibilite="[3.0.5;4.1.*]"
logo="prive/themes/spip/images/partenaires-64.png"
documentation=""
schema="1.5.3"

6
partenaires_pipelines.php

@ -21,7 +21,7 @@ function partenaires_affiche_milieu($flux) {
// partenaires sur les objets sélectionnées
$config = lire_config('partenaires', array());
$objets_partenaires = isset($config['objets']) ? $config['objets'] : array();
if (!$e['edition'] AND in_array($e['type'], $objets_partenaires)) {
if (empty($e['edition']) AND isset($e['type']) AND in_array($e['type'], $objets_partenaires)) {
$texte .= recuperer_fond('prive/objets/editer/liens', array(
'table_source' => 'partenaires',
'objet' => $e['type'],
@ -31,7 +31,7 @@ function partenaires_affiche_milieu($flux) {
// partenaires_types sur les partenaires
if (!$e['edition'] AND in_array($e['type'], array('partenaire'))) {
if (empty($e['edition']) AND isset($e['type']) AND in_array($e['type'], array('partenaire'))) {
$texte .= recuperer_fond('prive/objets/editer/liens', array(
'table_source' => 'partenaires_types',
'objet' => $e['type'],
@ -40,7 +40,7 @@ function partenaires_affiche_milieu($flux) {
}
if ($texte) {
if ($p = strpos($flux['data'], "<!--affiche_milieu-->")) {
if ( $p = strpos($flux['data'], "<!--affiche_milieu-->")) {
$flux['data'] = substr_replace($flux['data'], $texte, $p, 0);
} else {
$flux['data'] .= $texte;

Loading…
Cancel
Save