Browse Source

fix : compatibilité de la mise à jour SPIP 4 et avant

master v2.4.7
RealET 3 months ago
parent
commit
94e93d57be
  1. 2
      paquet.xml
  2. 9
      simplecal_administrations.php

2
paquet.xml

@ -1,7 +1,7 @@
<paquet
prefix="simplecal"
categorie="date"
version="2.4.6"
version="2.4.7"
etat="stable"
compatibilite="[3.2.0;4.0.*]"
logo="prive/themes/spip/images/evenement-32.png"

9
simplecal_administrations.php

@ -61,7 +61,14 @@ function simplecal_upgrade($nom_meta_base_version,$version_cible){
);
// SPIP 3
include_spip('maj/svn10000'); // migration des mots cles/auteurs
// migration des mots cles/auteurs
if (_SPIP_VERSION_ID < 40000) {
// Avant SPIP 4.0
include_spip('maj/svn10000');
} else {
include_spip('maj/legacy/svn10000');
}
$maj['2.0.0'] = array(
array('sql_alter',"TABLE spip_evenements ADD lang varchar(10) NOT NULL DEFAULT '' AFTER statut"),
array('sql_alter',"TABLE spip_evenements ADD langue_choisie varchar(3) NULL DEFAULT 'non' AFTER lang"),

Loading…
Cancel
Save