Browse Source

PHP8 : Fatal error à l'installation

master v2.0.1
Peetdu 10 months ago
parent
commit
e5727ab05f
  1. 2
      paquet.xml
  2. 2
      swiper_administrations.php

2
paquet.xml

@ -1,7 +1,7 @@
<paquet
prefix="swiper"
categorie="multimedia"
version="2.0.0"
version="2.0.1"
etat="test"
compatibilite="[3.2.0;4.0.*]"
logo="prive/themes/spip/images/swiper-64.png"

2
swiper_administrations.php

@ -37,7 +37,7 @@ function swiper_upgrade($nom_meta_base_version, $version_cible) {
if (!in_array("spip_swipers", $d))
ecrire_meta('documents_objets', $c."spip_swipers,");
$s = lire_config('swiper');
$s = lire_config('swiper', array());
if (!in_array("swiper_options", $s))
ecrire_config('swiper/swiper_options', "{\nkeyboard : true,\npagination: {\nel: '.swiper-pagination',\ntype: 'bullets'\n},\nscrollbar: {\nel: '.swiper-scrollbar',\ndraggable: true\n},\nnavigation: {\nnextEl: '.swiper-button-next',\nprevEl: '.swiper-button-prev'\n}\n}");

Loading…
Cancel
Save