Browse Source

prepare to composer 2.0 API

pull/1/head 0.4.0
JamesRezo 1 year ago
parent
commit
1c04b4cec0
  1. 8
      composer.json
  2. 978
      composer.lock
  3. 10
      src/SpipInstallerPlugin.php

8
composer.json

@ -11,11 +11,11 @@
],
"require": {
"php": "^5.3|^7",
"composer-plugin-api": "^1.0"
"composer-plugin-api": "^1.0 || ^2.0"
},
"config": {
"platform": {
"php": "5.3.29"
"php": "5.6.40"
}
},
"extra": {
@ -32,7 +32,7 @@
}
},
"require-dev": {
"phpunit/phpunit": "^4.8",
"composer/composer": "^1.6"
"composer/composer": "^1.10",
"phpunit/phpunit": "^5.7"
}
}

978
composer.lock
File diff suppressed because it is too large
View File

10
src/SpipInstallerPlugin.php

@ -13,4 +13,14 @@ class SpipInstallerPlugin implements PluginInterface
$installer = new SpipInstaller($io, $composer);
$composer->getInstallationManager()->addInstaller($installer);
}
public function deactivate(Composer $composer, IOInterface $io)
{
}
public function uninstall(Composer $composer, IOInterface $io)
{
}
}
Loading…
Cancel
Save