Browse Source

On passe sur le nouveau plugin "Font Awesome 5 - Police" pour mutualiser et on répare le picto du menu burger au passage.

Pour une raison que j'ignore, le styles d'origine ne marchent pas avec FA5, donc on doit ajouter la classe .fas via le script.
master v0.4.0
jeanmarie 2 years ago
parent
commit
bfaf92d3db
  1. 5
      css/fontawesome-all.min.css
  2. 6
      css/main.css
  3. 2
      javascript/main.js
  4. 4
      paquet.xml

5
css/fontawesome-all.min.css vendored

File diff suppressed because one or more lines are too long

6
css/main.css

@ -1884,7 +1884,7 @@ input, select, textarea {
.icon:before {
display: inline-block;
font-family: FontAwesome;
font-family: "Font Awesome 5 Free";
font-size: 1.25em;
text-decoration: none;
font-style: normal;
@ -2598,10 +2598,10 @@ input, select, textarea {
-webkit-transition: all .15s ease-in-out;
-ms-transition: all .15s ease-in-out;
transition: all .15s ease-in-out;
font-family: FontAwesome;
font-family: "Font Awesome 5 Free";
text-decoration: none;
font-style: normal;
font-weight: normal;
/*font-weight: normal;*/
-webkit-font-smoothing: antialiased;
-moz-osx-font-smoothing: grayscale;
content: '\f0c9';

2
javascript/main.js

@ -37,7 +37,7 @@
// Title Bar.
$(
'<div id="titleBar">' +
'<a href="#navPanel" class="toggle"></a>' +
'<a href="#navPanel" class="toggle fas"></a>' +
'<span class="title">' + $('#logo h1').html() + '</span>' +
'</div>'
)

4
paquet.xml

@ -1,7 +1,7 @@
<paquet
prefix="html5up_escape_velocity"
categorie="squelette"
version="0.3.0"
version="0.4.0"
etat="dev"
compatibilite="[3.2.0;3.3.*]"
documentation="https://git.spip.net/spip-contrib-squelettes/html5up_escape_velocity/src/branch/master/README.md"
@ -18,12 +18,12 @@
<credit lien="https://html5up.net/escape-velocity">HTML5UP (Escape Velocity)</credit>
<credit lien="http://fontawesome.io/license/">Font Awesome</credit>
<style source="css/fontawesome-all.min.css" />
<style source="css/main.css" type="public" />
<necessite nom="adaptive_images" compatibilite="[2.0.0;]" />
<necessite nom="compositions" compatibilite="[3.8.0;]" />
<utilise nom="contact" compatibilite="[0.16.0;]" />
<necessite nom="fontawesome5" compatibilite="[5.14.0;]" />
<utilise nom="identite_extra" compatibilite="[1.4.0;]" />
<utilise nom="mailsubscribers" compatibilite="[2.14.0;]" />
<utilise nom="oembed" compatibilite="[2.0.0;]" />

Loading…
Cancel
Save