Browse Source

extension sodium requise (#5074)

Co-authored-by: JamesRezo <james@rezo.net>
Reviewed-on: #5074
Co-authored-by: JamesRezo <jamesrezo@noreply.git.spip.net>
Co-committed-by: JamesRezo <jamesrezo@noreply.git.spip.net>
remotes/checkIfPRContentChanged-1646558585347164415/master
JamesRezo 7 months ago
parent
commit
ecc129d80a
  1. 1
      composer.json
  2. 2
      ecrire/inc/install.php

1
composer.json

@ -1,6 +1,7 @@
{
"require": {
"php": "^7.4 || ^8.0",
"ext-sodium": "*",
"ext-xml": "*",
"ext-zip": "*"
},

2
ecrire/inc/install.php

@ -173,7 +173,7 @@ function tester_compatibilite_hebergement() {
$err[] = _T('install_php_version_max', ['version' => $p, 'maximum' => _PHP_MAX]);
}
$diff = array_diff(['xml', 'zip'], get_loaded_extensions());
$diff = array_diff(['sodium', 'xml', 'zip'], get_loaded_extensions());
if (!empty($diff)) {
$err[] = _T('install_php_extension', ['extensions' => implode(',', $diff)]);
}

Loading…
Cancel
Save