PostGreSQL - Plugin Menu #1988

Open
opened 11 years ago by goldstein · 3 comments
Owner

Bonjour,

j'ai installé SPIP (2.1.2) avec une base de données PostGreSQL, ainsi que les plugins ZPIP (1.7.9), Menu (0.8.3), etc.

J'ai créé un menu, avec deux entrées, et au moment de le visualiser en ligne, depuis le lien de la page
.../ecrire/?exec=menus_editer&id_menu=1
(le lien est
.../ecrire/?exec=menus_editer&action=redirect&type=menu&id=1&var_mode=calcul)
je recois une erreur 302:
"
Warning: pg_query() [function.pg-query]: Query failed: ERROR: error de sintaxis en o cerca de «AS» LINE 2: FROM spip_menus AS O LEFT JOIN spip_urls AS U ON (U.type='me... ^ in /var/www/sitio_atlas/ecrire/req/pg.php on line 151
HTTP 302
Si tu navegador no te redirige automaticamente, pincha aquí para continuar.
"

En utilisant var_mode=debug:
.../ecrire/?exec=menus_editer&action=redirect&type=menu&id=1&var_mode=debug,
j'ai la même erreur, comme si l'erreur avait lieu avant l'appel au déboggueur.
Du coup, je ne sais pas comment voir quel est le problème. Une idée ?

Je précise que le menu n'apparait pas dans la partie publique (j'utilise le thème BluePigment 1.0 qui affiche normalement le menu sans problème).

Severo

Bonjour, j'ai installé SPIP (2.1.2) avec une base de données [[PostGreSQL]], ainsi que les plugins ZPIP (1.7.9), Menu (0.8.3), etc. J'ai créé un menu, avec deux entrées, et au moment de le visualiser en ligne, depuis le lien de la page .../ecrire/?exec=menus_editer&id_menu=1 (le lien est .../ecrire/?exec=menus_editer&action=redirect&type=menu&id=1&var_mode=calcul) je recois une erreur 302: " Warning: pg_query() [function.pg-query]: Query failed: ERROR: error de sintaxis en o cerca de «AS» LINE 2: FROM spip_menus AS O LEFT JOIN spip_urls AS U ON (U.type='me... ^ in /var/www/sitio_atlas/ecrire/req/pg.php on line 151 HTTP 302 Si tu navegador no te redirige automaticamente, pincha aquí para continuar. " En utilisant var_mode=debug: .../ecrire/?exec=menus_editer&action=redirect&type=menu&id=1&var_mode=debug, j'ai la même erreur, comme si l'erreur avait lieu avant l'appel au déboggueur. Du coup, je ne sais pas comment voir quel est le problème. Une idée ? Je précise que le menu n'apparait pas dans la partie publique (j'utilise le thème [[BluePigment]] 1.0 qui affiche normalement le menu sans problème). Severo
Owner

Version cible mise à 3.1

**Version cible mise à 3.1**
Owner

Version cible mise à 3.2

**Version cible mise à 3.2**
Owner

Version cible mise à 90. PostgreSQL

**Version cible mise à 90. PostgreSQL**
cy.altern added the
PostgreSQL
label 1 week ago
cy.altern removed this from the (deleted) milestone 1 week ago
Sign in to join this conversation.
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.