IE 11 et couleur de l'espace privé #3300

Closed
opened 8 years ago by Franck · 6 comments
Franck commented 8 years ago

Bonjour :-)
Sous IE11 (Windows 7)
Php 5.4
SPIP 3.0.18-dev [21616]

Quand on veux changer les couleurs via .../ecrire/?exec=configurer_preferences le changement de couleurs ne fonctionne pas du premier coup.
Il faut changer deux fois de couleurs pour que le système fonctionne normalement !
Par contre, une fois que le système fonctionne, les icônes du bandeau d'administration (acceuil, edition, ...) disparaissent, ils réapparaissent si l'on clique sur par exemple "acceil"
Pour infos, le problème est également présent sur SPIP 3.1.0-dev SVN [21623]

Bonjour :-) Sous IE11 (Windows 7) Php 5.4 SPIP 3.0.18-dev [21616] Quand on veux changer les couleurs via .../ecrire/?exec=configurer_preferences le changement de couleurs ne fonctionne pas du premier coup. Il faut changer deux fois de couleurs pour que le système fonctionne normalement ! Par contre, une fois que le système fonctionne, les icônes du bandeau d'administration (acceuil, edition, ...) disparaissent, ils réapparaissent si l'on clique sur par exemple "acceil" Pour infos, le problème est également présent sur SPIP 3.1.0-dev SVN [21623]

Bonjour,

Je confirme le bug sous IE11 & W7. Le bug persiste en SPIP 3.1.0

Bonjour, Je confirme le bug sous IE11 & W7. Le bug persiste en SPIP 3.1.0

Désolé pour le double-post. Le soucis est connu sous IE11 :
http://stackoverflow.com/questions/1184950/dynamically-loading-css-stylesheet-doesnt-work-on-ie

Désolé pour le double-post. Le soucis est connu sous IE11 : http://stackoverflow.com/questions/1184950/dynamically-loading-css-stylesheet-doesnt-work-on-ie
Owner

Version cible mise à 3.1

**Version cible mise à 3.1**
b_b commented 7 years ago
Owner

La solution la plus adaptée semble être la suivante :

You need to set the href attr last and only after the link elem is appended to the head

http://stackoverflow.com/a/5541628

J'ai un patch que Franck vient de tester, et il me confirme que ça fonctionne, j'envoie ça tout de suite.

La solution la plus adaptée semble être la suivante : > You need to set the href attr last and only after the link elem is appended to the head http://stackoverflow.com/a/5541628 J'ai un patch que Franck vient de tester, et il me confirme que ça fonctionne, j'envoie ça tout de suite.

Appliqué par commit r22971.
Statut changé à Fermé

Appliqué par commit r22971. **Statut changé à Fermé**
b_b commented 6 years ago
Owner
There is no content yet.
Sign in to join this conversation.
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.