Le menu développement ne disparait pas #3417

Closed
opened 8 years ago by Franck · 7 comments
Franck commented 8 years ago

SPIP 3.1.0-alpha [21968]
PHP 5.6.6
Installation en MySQL

Boujour,
Quand je vais dans ecrire/?exec=configurer_preferences et que je décoche la case "Afficher le menu Développement" que j'avais cocher auparavant.
J'ai bien le message "La nouvelle configuration a été enregistrée" qui apparait, sauf que le menu reste, présent !
Je vais voir une autre page, exemple: ecrire/?exec=accueil puis que je retourne voir la page "ecrire/?exec=configurer_preferences"
La case est de nouveau cocher, y compris si je vide le cache, avant de retourner voir "ecrire/?exec=configurer_preferences"
Franck

SPIP 3.1.0-alpha [21968] PHP 5.6.6 Installation en MySQL Boujour, Quand je vais dans ecrire/?exec=configurer_preferences et que je décoche la case "Afficher le menu Développement" que j'avais cocher auparavant. J'ai bien le message "La nouvelle configuration a été enregistrée" qui apparait, sauf que le menu reste, présent ! Je vais voir une autre page, exemple: ecrire/?exec=accueil puis que je retourne voir la page "ecrire/?exec=configurer_preferences" La case est de nouveau cocher, y compris si je vide le cache, avant de retourner voir "ecrire/?exec=configurer_preferences" Franck
b_b commented 8 years ago
Owner

ha oui, je reproduis et maintenant je ne peux plus m'en débarrasser :p

ha oui, je reproduis et maintenant je ne peux plus m'en débarrasser :p
b_b commented 8 years ago
Owner

Le problème vient certainement de r21657 dans le traitement du formulaire configurer_preferences.

Le problème vient certainement de r21657 dans le traitement du formulaire configurer_preferences.
b_b commented 8 years ago
Owner

Assigné à tonton pour la peine :p
Assigné à Eric

Assigné à tonton pour la peine :p **Assigné à Eric**
b_b commented 8 years ago
Owner

Il faudrait modifier le formulaire comme indiqué dans le patch joint, mais cela ne suffit pas car l'autorisation qui conditionne l'affichage du menu ne teste pas la valeur de la globale, mais uniquement le fait qu'elle soit remplie...

Il faudrait modifier le formulaire comme indiqué dans le patch joint, mais cela ne suffit pas car l'autorisation qui conditionne l'affichage du menu ne teste pas la valeur de la globale, mais uniquement le fait qu'elle soit remplie...
Owner

Corrigé par http://core.spip.org/projects/spip/repository/revisions/21970.
Reste à trouver pourquoi l'affichage de l'icone se fait en deux temps.
Statut changé à Résolu

Corrigé par http://core.spip.org/projects/spip/repository/revisions/21970. Reste à trouver pourquoi l'affichage de l'icone se fait en deux temps. **Statut changé à Résolu**
b_b commented 8 years ago
Owner

Je ferme, mais il reste tout de même un problème de cache lors du changement de pref.

Il faut un rechargement ou un changement de page pour voir le bouton, et sur ma config de test je dois vider le cache pour que son icône soit visible. J'ai bien tenté d'appliquer le patch ci-joint mais même le refus d'ajax + une invalidation de cache ne fixent pas le pb. À suivre ici ou dans un nouveau ticket...
Statut changé à Fermé

Je ferme, mais il reste tout de même un problème de cache lors du changement de pref. Il faut un rechargement ou un changement de page pour voir le bouton, et sur ma config de test je dois vider le cache pour que son icône soit visible. J'ai bien tenté d'appliquer le patch ci-joint mais même le refus d'ajax + une invalidation de cache ne fixent pas le pb. À suivre ici ou dans un nouveau ticket... **Statut changé à Fermé**
b_b commented 8 years ago
Owner

Voir #3388.

Voir #3388.
Sign in to join this conversation.
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.