Impossibilité d'écrire "javascript:" ou "data:" dans le texte d'un article #3809

Closed
opened 7 years ago by miros · 8 comments
miros commented 7 years ago

SPIP 3.1.1 [22913]

Il est impossible d'écrire "javascript:" ou "data:" dans le texte d'un article, que ce soit dans une balise `, ou simplement sans balise. Lors de l'enregistrement, une boîte rose avec le texte suivant apparaît : "Oups. Une erreur inattendue a empêché de soumettre le formulaire. Vous pouvez essayer à nouveau.".

Voici un exemple qui ne fonctionne pas :

`javascript:void(location.href=%22https://ezproxy.bibl.ulaval.ca/login?url=%22+location.href)` 

ou simplement :

javascript:

SPIP 3.1.1 [22913] Il est impossible d'écrire "javascript:" ou "data:" dans le texte d'un article, que ce soit dans une balise `, <cadre> ou simplement sans balise. Lors de l'enregistrement, une boîte rose avec le texte suivant apparaît : "Oups. Une erreur inattendue a empêché de soumettre le formulaire. Vous pouvez essayer à nouveau.". Voici un exemple qui ne fonctionne pas : <pre> `javascript:void(location.href=%22https://ezproxy.bibl.ulaval.ca/login?url=%22+location.href)` </pre> ou simplement : javascript:
b_b commented 7 years ago
Owner

Version cible mise à 3.1

**Version cible mise à 3.1**
b_b commented 7 years ago
Owner

Salut et merci pour le signalement, de mon côté je ne reproduis pas le bug que ça soit sous SPIP 3.1.1 SVN [23110] ou SPIP 3.2.

As-tu activé le mode "parano" avec $filtrer_javascript = -1; ?

Salut et merci pour le signalement, de mon côté je ne reproduis pas le bug que ça soit sous SPIP 3.1.1 SVN [23110] ou SPIP 3.2. As-tu activé le mode "parano" avec `$filtrer_javascript = -1;` ?
Poster

Non, je n'ai pas activé cette fonction. Je vais vérifier de nouveau à la sortie de la prochaine version puisque vous n'avez pas ce problème avec la svn.

Petite précision, c'est en modifiant des articles déjà en ligne que j'ai observé le problème, je n'ai pas testé avec un nouvel article, c'est peut-être différent.

Non, je n'ai pas activé cette fonction. Je vais vérifier de nouveau à la sortie de la prochaine version puisque vous n'avez pas ce problème avec la svn. Petite précision, c'est en modifiant des articles déjà en ligne que j'ai observé le problème, je n'ai pas testé avec un nouvel article, c'est peut-être différent.
b_b commented 7 years ago
Owner

Idem avec un article publié ou avec un nouveau, je ne reproduis toujours pas.

Idem avec un article publié ou avec un nouveau, je ne reproduis toujours pas.
Poster

Je viens de tester avec la version 23114, j'ai toujours le même problème. De plus ça ne provient pas des plugins activés.

Si je clique une deuxième fois sur enregistrer (après le carré rose), je suis redirigé vers un erreur 403 (Forbidden).

Je viens de tester avec la version 23114, j'ai toujours le même problème. De plus ça ne provient pas des plugins activés. Si je clique une deuxième fois sur enregistrer (après le carré rose), je suis redirigé vers un erreur 403 (Forbidden).
b_b commented 7 years ago
Owner

Pas de nouvelle de ce bug ? Ça sent le problème amha, je ne reproduis toujours pas. On pourrait fermer le ticket si pas de nouvelle...

Pas de nouvelle de ce bug ? Ça sent le problème amha, je ne reproduis toujours pas. On pourrait fermer le ticket si pas de nouvelle...
b_b commented 7 years ago
Owner

Statut changé à En cours

**Statut changé à En cours**
Owner

Je ne reproduis pas non plus l'erreur.
Je ferme ce ticket

Statut changé à Fermé

Je ne reproduis pas non plus l'erreur. Je ferme ce ticket **Statut changé à Fermé**
Sign in to join this conversation.
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.