.spip_logo #3862

Closed
opened 6 years ago by miros · 6 comments
miros commented 6 years ago

Bonjour,
il me semble qu'il y a un problème avec les classes spip.css/.spip_logo (deux lignes) alors que .spip_logo_site n'est pas définie (ni .spip_logos, qui apparaît aussi dans le code source généré). La première définition (.spip_logo { float:right; margin: 0 0 10px 10px; padding:0; border: 1px solid Red; }) m’empêche de centrer une image (le logo de l'article) dans une boite flex (en tout cas si je la mets en commentaire le problème disparait); mais la mettre en commentaire mets le logo du site à droite du titre (c'est moins problématique). Et la changer en .spip_logo_site ne donne pas non plus le résultat attendu.

Bon, peut-être que je suis un peu clé à mollette pour le code...

Je travaille sur SPIP 3.1.3 [23214]

Cordialement, J. A. ZAMBRANO

Bonjour, il me semble qu'il y a un problème avec les classes spip.css/.spip_logo (deux lignes) alors que .spip_logo_site n'est pas définie (ni .spip_logos, qui apparaît aussi dans le code source généré). La première définition (.spip_logo { float:right; margin: 0 0 10px 10px; padding:0; border: 1px solid Red; }) m’empêche de centrer une image (le logo de l'article) dans une boite flex (en tout cas si je la mets en commentaire le problème disparait); mais la mettre en commentaire mets le logo du site à droite du titre (c'est moins problématique). Et la changer en .spip_logo_site ne donne pas non plus le résultat attendu. Bon, peut-être que je suis un peu clé à mollette pour le code... Je travaille sur SPIP 3.1.3 [23214] Cordialement, J. A. ZAMBRANO

Bonjour,
je ne comprends peut-être pas bien, mais est-ce un problème sur un squelettes-dist de SPIP ou bien un squelettes déjà modifié ?
J'ai l'impression que c'est un problème d'affichage personnalisé, et si c'est le cas il faut plutôt s'adresser aux listes SPIP ou au forums...

Bonjour, je ne comprends peut-être pas bien, mais est-ce un problème sur un squelettes-dist de SPIP ou bien un squelettes déjà modifié ? J'ai l'impression que c'est un problème d'affichage personnalisé, et si c'est le cas il faut plutôt s'adresser aux listes SPIP ou au forums...
Poster

bonjour,

"est-ce un problème sur un squelettes-dist de SPIP ou bien un squelettes
déjà modifié ? "
Les deux mon capitaine :-)
Je fais un site pour une amie, je prends spip et je fait quelques
modifications (j’allège) à partir des squelettes-dist. L'entête de la dist
me vas parfait, mais...
Je fais une page "catalogue" (rubrique) pour afficher les articles, et je
me lance dans une flexbox grids
http://codepen.io/raphaelgoetter/pen/mzKrh?editors=110 qui m'afficherait
le titre et le logo de l'article. Juste modifier la classe dans le
squelette de la rubrique et le tour est joué:
<B_articles>

bonjour, "est-ce un problème sur un squelettes-dist de SPIP ou bien un squelettes déjà modifié ? " Les deux mon capitaine :-) Je fais un site pour une amie, je prends spip et je fait quelques modifications (j’allège) à partir des squelettes-dist. L'entête de la dist me vas parfait, mais... Je fais une page "catalogue" (rubrique) pour afficher les articles, et je me lance dans une flexbox grids <http://codepen.io/raphaelgoetter/pen/mzKrh?editors=110> qui m'afficherait le titre et le logo de l'article. Juste modifier la classe dans le squelette de la rubrique et le tour est joué: <B_articles> <div class="menu menu_articles"> <ul class="grid-4"> (merci spip!). Mais là, pas moyen de centrer cette image (le logo)... jusqu'à ce que je me résolve à aller fouiner spip.css pour voir qu'est-ce qu'il fait dans la mise en forme des balises, en comparant avec le html généré. C'est là que je vois que la classe spip_logo_site n'est pas définie (ni spip_logos, qui apparaît aussi dans le html généré), et spip_logo l'est deux fois (je veux dire il y a deux lignes pour). Et comment le header est vraiment un condensé de "parlez-vous spip?"... Ensuite, est-ce qu'il y a réellement un problème de core? Je ne mettrait pas ma main à couper, je ne suis pas assez fort en codage pour, et je tiens à mes mains :-) En tout cas, si je mets en commentaire la première définition de .spip_logo je peux centrer l'image facilement:([(#LOGO_ARTICLE|*center* |#URL_ARTICLE|image_reduire{300,*})]) En vous remerciant, cordialement, J. Alberto ZAMBRANO Le 22 novembre 2016 à 08:55, <redmine`spip.org> a écrit : > La demande #3862 a été mise à jour par chan kalan. > > > Bonjour, > je ne comprends peut-être pas bien, mais est-ce un problème sur un > squelettes-dist de SPIP ou bien un squelettes déjà modifié ? > J'ai l'impression que c'est un problème d'affichage personnalisé, et si > c'est le cas il faut plutôt s'adresser aux listes SPIP ou au forums... > ------------------------------ > Anomalie #3862: .spip_logo > <https://core.spip.net/issues/3862#change-12212> > > - Auteur: J. Alberto ZAMBRANO > - Statut: Nouveau > - Priorité: Normal > - Assigné à: > - Catégorie: css > - Version cible: 3.1 > - Resolution: > - Navigateur: > > Bonjour, > il me semble qu'il y a un problème avec les classes spip.css/.spip_logo > (deux lignes) alors que .spip_logo_site n'est pas définie (ni .spip_logos, > qui apparaît aussi dans le code source généré). La première définition > (.spip_logo { float:right; margin: 0 0 10px 10px; padding:0; border: 1px > solid Red; }) m’empêche de centrer une image (le logo de l'article) dans > une boite flex (en tout cas si je la mets en commentaire le problème > disparait); mais la mettre en commentaire mets le logo du site à droite du > titre (c'est moins problématique). Et la changer en .spip_logo_site ne > donne pas non plus le résultat attendu. > > Bon, peut-être que je suis un peu clé à mollette pour le code... > > Je travaille sur SPIP 3.1.3 [23214] > > Cordialement, J. A. ZAMBRANO > Fichiers problème css spip_logo.docx > <https://core.spip.net/attachments/download/866/proble%CC%80me%20css%20spip_logo.docx> > (565,061 ko) > ------------------------------ > > Vous recevez ce mail car vous êtes impliqués sur ce projet. > Pour changer les préférences d'envoi de mail, allez sur > http://core.spip.org/my/account >
b_b commented 6 years ago
Owner

Ça ressemble plus à une demande d'aide qu'à une déclaration de bug, du coup, je me permets de fermer ce ticket et tu devrais poser ta question sur la liste http://listes.rezo.net/mailman/listinfo/spip/
Statut changé à Fermé

Ça ressemble plus à une demande d'aide qu'à une déclaration de bug, du coup, je me permets de fermer ce ticket et tu devrais poser ta question sur la liste http://listes.rezo.net/mailman/listinfo/spip/ **Statut changé à Fermé**
Poster

hola,

"Ça ressemble plus à une demande d'aide qu'à une déclaration de bug"

au temps pour moi. Mais pour ce qui est de l'aide, une fois que j'ai trouvé
le moyen de centrer les images (en mettant en commentaire une ligne dans
spip.css, même si ça ne se fait pas) je n'avais plus de problème, modifier
le inclure/header reste à ma porté. Par contre je signalais le fait que
dans les fichiers css (notamment spip.css) certaines déclarations sont
absentes, et/ou que le html généré n'y correspond pas.
Mais peut-être je n'ai pas compris ou mal fait quelque chose. Merci pour
l'attention, et désolé pour la perte de temps.
Cordialement, J. Alberto ZAMBRANO

Le 22 novembre 2016 à 17:17, <redmine`spip.org> a écrit :

La demande #3862 a été mise à jour par b b.

  • Statut changé de Nouveau à Fermé
  • Resolution mis à invalid

Ça ressemble plus à une demande d'aide qu'à une déclaration de bug, du
coup, je me permets de fermer ce ticket et tu devrais poser ta question sur
la liste http://listes.rezo.net/mailman/listinfo/spip/

Anomalie #3862: .spip_logo
https://core.spip.net/issues/3862#change-12214

  • Auteur: J. Alberto ZAMBRANO
  • Statut: Fermé
  • Priorité: Normal
  • Assigné à:
  • Catégorie: css
  • Version cible: 3.1
  • Resolution: invalid
  • Navigateur:

Bonjour,
il me semble qu'il y a un problème avec les classes spip.css/.spip_logo
(deux lignes) alors que .spip_logo_site n'est pas définie (ni .spip_logos,
qui apparaît aussi dans le code source généré). La première définition
(.spip_logo { float:right; margin: 0 0 10px 10px; padding:0; border: 1px
solid Red; }) m’empêche de centrer une image (le logo de l'article) dans
une boite flex (en tout cas si je la mets en commentaire le problème
disparait); mais la mettre en commentaire mets le logo du site à droite du
titre (c'est moins problématique). Et la changer en .spip_logo_site ne
donne pas non plus le résultat attendu.

Bon, peut-être que je suis un peu clé à mollette pour le code...

Je travaille sur SPIP 3.1.3 [23214]

Cordialement, J. A. ZAMBRANO
Fichiers problème css spip_logo.docx
https://core.spip.net/attachments/download/866/proble%CC%80me%20css%20spip_logo.docx
(565,061 ko)

Vous recevez ce mail car vous êtes impliqués sur ce projet.
Pour changer les préférences d'envoi de mail, allez sur
http://core.spip.org/my/account

hola, *"Ça ressemble plus à une demande d'aide qu'à une déclaration de bug"* au temps pour moi. Mais pour ce qui est de l'aide, une fois que j'ai trouvé le moyen de centrer les images (en mettant en commentaire une ligne dans spip.css, même si ça ne se fait pas) je n'avais plus de problème, modifier le inclure/header reste à ma porté. Par contre je signalais le fait que dans les fichiers css (notamment spip.css) certaines déclarations sont absentes, et/ou que le html généré n'y correspond pas. Mais peut-être je n'ai pas compris ou mal fait quelque chose. Merci pour l'attention, et désolé pour la perte de temps. Cordialement, J. Alberto ZAMBRANO Le 22 novembre 2016 à 17:17, <redmine`spip.org> a écrit : > La demande #3862 a été mise à jour par b b. > > - *Statut* changé de *Nouveau* à *Fermé* > - *Resolution* mis à *invalid* > > Ça ressemble plus à une demande d'aide qu'à une déclaration de bug, du > coup, je me permets de fermer ce ticket et tu devrais poser ta question sur > la liste http://listes.rezo.net/mailman/listinfo/spip/ > ------------------------------ > Anomalie #3862: .spip_logo > <https://core.spip.net/issues/3862#change-12214> > > - Auteur: J. Alberto ZAMBRANO > - Statut: Fermé > - Priorité: Normal > - Assigné à: > - Catégorie: css > - Version cible: 3.1 > - Resolution: invalid > - Navigateur: > > Bonjour, > il me semble qu'il y a un problème avec les classes spip.css/.spip_logo > (deux lignes) alors que .spip_logo_site n'est pas définie (ni .spip_logos, > qui apparaît aussi dans le code source généré). La première définition > (.spip_logo { float:right; margin: 0 0 10px 10px; padding:0; border: 1px > solid Red; }) m’empêche de centrer une image (le logo de l'article) dans > une boite flex (en tout cas si je la mets en commentaire le problème > disparait); mais la mettre en commentaire mets le logo du site à droite du > titre (c'est moins problématique). Et la changer en .spip_logo_site ne > donne pas non plus le résultat attendu. > > Bon, peut-être que je suis un peu clé à mollette pour le code... > > Je travaille sur SPIP 3.1.3 [23214] > > Cordialement, J. A. ZAMBRANO > Fichiers problème css spip_logo.docx > <https://core.spip.net/attachments/download/866/proble%CC%80me%20css%20spip_logo.docx> > (565,061 ko) > ------------------------------ > > Vous recevez ce mail car vous êtes impliqués sur ce projet. > Pour changer les préférences d'envoi de mail, allez sur > http://core.spip.org/my/account >
b_b commented 6 years ago
Owner

Pas de problème :)

Pour ce qui est des classes css : .spip_logo_site est bien définie dans layout.css cf http://zone.spip.org/trac/spip-zone/browser/core/plugins/dist/css/layout.css#L26

La classe spip_logos n'est pas définie car c'est un alias de spip_logo (d'où la présence des deux dans le source), le temps qu'on passe de l'un à l'autre.

Pas de problème :) Pour ce qui est des classes css : .spip_logo_site est bien définie dans layout.css cf http://zone.spip.org/trac/spip-zone/browser/_core_/plugins/dist/css/layout.css#L26 La classe spip_logos n'est pas définie car c'est un alias de spip_logo (d'où la présence des deux dans le source), le temps qu'on passe de l'un à l'autre.
Poster

hola,
bon, je suis peut-être clé à molette, mais:
sur un site spip "vierge" je crée une rubrique + (un article avec logo).
Je veux que le logo de l'article soit centré
Je vais dans article.html (comme je suis clé à molette, je le copie dans un dossier squelettes) et je modifie juste la ligne:

[(#LOGO_ARTICLE_RUBRIQUE|image_reduire{150,*}) ]#TITRE

_par:_

[(#LOGO_ARTICLE_RUBRIQUE|center|image_reduire{150,*}) ]#TITRE

_(http://www.spip.net/fr_article4652.html)_ _mais ça ne marchera pas, parce que dans spip.logos j'ai:_ /* Logos, documents et images */ .spip_logo { float:right; margin: 0 0 10px 10px; padding:0; border: none; }

.spip_logo { margin: 0 0 10px 10px; padding: 0; border: none; }
.spip_logo_center { clear: both; display: block; margin: 0 auto 1.5em auto; }
.spip_logo_left { float: left; margin-right: 1.5em; margin-bottom: 1.5em; }
.spip_logo_right { float: right; margin-left: 1.5em; margin-bottom: 1.5em; }
et que le html généré fera spip_logo spip_logo_center et donc ça va toujours flotter à droite...
J'ai corrigé par une déclaration perso:

.spip_logo_center { float:none; clear: both; display: block; margin: 0 auto 1.5em auto; }
mais je trouve que si je dois faire ça, c'est une anomalie...
_
Cordialement, J. A. Z._

_hola, bon, je suis peut-être clé à molette, mais: sur un site spip "vierge" je crée une rubrique + (un article avec logo). Je veux que le logo de l'article soit centré Je vais dans article.html (comme je suis clé à molette, je le copie dans un dossier squelettes) et je modifie juste la ligne:_ <h1 class="#EDIT{titre} surlignable">[(#LOGO_ARTICLE_RUBRIQUE|image_reduire{150,*}) ]#TITRE</h1> _par:_ <h1 class="#EDIT{titre} surlignable">[(#LOGO_ARTICLE_RUBRIQUE|center|image_reduire{150,*}) ]#TITRE</h1> _(http://www.spip.net/fr_article4652.html)_ _mais ça ne marchera pas, parce que dans spip.logos j'ai:_ /* Logos, documents et images */ .spip_logo { float:right; margin: 0 0 10px 10px; padding:0; border: none; } .spip_logo { margin: 0 0 10px 10px; padding: 0; border: none; } .spip_logo_center { clear: both; display: block; margin: 0 auto 1.5em auto; } .spip_logo_left { float: left; margin-right: 1.5em; margin-bottom: 1.5em; } .spip_logo_right { float: right; margin-left: 1.5em; margin-bottom: 1.5em; } _et que le html généré fera spip_logo spip_logo_center et donc ça va toujours flotter à droite... J'ai corrigé par une déclaration perso:_ .spip_logo_center { float:none; clear: both; display: block; margin: 0 auto 1.5em auto; } _mais je trouve que si je dois faire ça, c'est une anomalie..._ _ Cordialement, J. A. Z._
Sign in to join this conversation.
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.