SVP ne propose pas nouvelle version #4829

Closed
opened 1 year ago by JLuc · 7 comments
JLuc commented 1 year ago

Après mise à jour d'un SPIP en SPIP 4 avec la constante permettant la compatibilité avec les plugins pas à jour, SVP ne propose pas la mise à jour de SAISIES en version 4 compatible SPIP4 et reste en 3.54.7.

Jack31 confirme avoir vécu la même chose.

Après mise à jour d'un SPIP en SPIP 4 avec la constante permettant la compatibilité avec les plugins pas à jour, SVP ne propose pas la mise à jour de SAISIES en version 4 compatible SPIP4 et reste en 3.54.7. Jack31 confirme avoir vécu la même chose.
Collaborator

Je pense que c'est parce que saisies v4 est en "test" et saisies v3 en "stable". Mais ca reste problématique.

Je pense que c'est parce que saisies v4 est en "test" et saisies v3 en "stable". Mais ca reste problématique.
Owner

en effet, il faut améliorer l'heuristique:

  • ne pas proposer la version 'test' si on est dans une version 'stable' est OK, sauf si il se trouve que la version 'stable' est non compatible avec notre version de SPIP (en ignorant la compatibilité forcée dans ce test)
en effet, il faut améliorer l'heuristique: - ne pas proposer la version 'test' si on est dans une version 'stable' est OK, sauf si il se trouve que la version 'stable' est non compatible avec notre version de SPIP (en ignorant la compatibilité forcée dans ce test)
JLuc commented 1 year ago
Poster

Effectivement : pareil aujourd'hui pour Notation et Memoization dont les nouvelles versions sont "en test".

L'amélioration de l'heuristique proposée corrige une situation bloquée à tort donc ce serait très bien.

De manière plus générale, plutôt que ne pas du tout proposer la mise à jour vers une version "en test", il semblerait intéressant de bien proposer la mise à jour, mais avec un avertissement.

Effectivement : pareil aujourd'hui pour Notation et Memoization dont les nouvelles versions sont "en test". L'amélioration de l'heuristique proposée corrige une situation bloquée à tort donc ce serait très bien. De manière plus générale, plutôt que ne pas du tout proposer la mise à jour vers une version "en test", il semblerait intéressant de bien proposer la mise à jour, mais avec un avertissement.
b_b added the
amélioration
label 1 year ago
b_b added this to the spip-4.1 milestone 1 year ago
JLuc commented 1 year ago
Poster

Cf #3670 « Pas de mise à jour proposée vers une version en état dev »

Mais sussi #3017 et en particulier ce commentaire de marcimat.

Cf #3670 « Pas de mise à jour proposée vers une version en état dev » Mais sussi #3017 et en particulier [ce commentaire de marcimat](https://git.spip.net/spip/svp/issues/3017#issuecomment-17966).
Owner

cf #4860 donc qui corrige au moins un cas d'usage

cf https://git.spip.net/spip/svp/pulls/4860 donc qui corrige au moins un cas d'usage
Owner

Maintenant que #4860 est intégré, faut-il garder ce ticket qui a un peu dévié de la question initiale ou le fermer et déplacer les suppléments dans un nouveau ticket ?

Maintenant que #4860 est intégré, faut-il garder ce ticket qui a un peu dévié de la question initiale ou le fermer et déplacer les suppléments dans un nouveau ticket ?
Owner

Pas de retour, on ferme :)

Pas de retour, on ferme :)
b_b closed this issue 2 months ago
Sign in to join this conversation.
No Milestone
No Assignees
4 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.