Browse Source

L'affichage de la "compatibilité forcée" était graphiquement cassé.

On le sort du titre, d'une part, et on met une phrase d'explication de ce que cela signifie.
master v1.1.8
marcimat@rezo.net 6 years ago
parent
commit
6758e456c4
  1. 12
      exec/admin_plugin.php
  2. 1
      lang/svp_fr.php
  3. 2
      paquet.xml

12
exec/admin_plugin.php

@ -107,11 +107,15 @@ function exec_admin_plugin_dist() {
echo debut_droite('plugin', true);
// alerte si mode de compatibilité forcée
$mode_compat = defined('_DEV_VERSION_SPIP_COMPAT') ?
'<span class="notice">' . _T('svp:alerte_compatibilite') . '</span>' : '';
echo gros_titre(_T('icone_admin_plugin'), '', false);
echo gros_titre(_T('icone_admin_plugin') . $mode_compat, '', false);
// alerte si mode de compatibilité forcée
if (defined('_DEV_VERSION_SPIP_COMPAT')) {
echo '<div class="notice">'
. '<strong>' . _T('svp:alerte_compatibilite') . '</strong><br />'
. _T('svp:alerte_compatibilite_version_autorisee', array('version' => _DEV_VERSION_SPIP_COMPAT))
. '</div>';
}
// message d'erreur au retour d'une operation
if ($erreur_activation) {

1
lang/svp_fr.php

@ -17,6 +17,7 @@ $GLOBALS[$GLOBALS['idx_lang']] = array(
'actions_realises' => 'Actions réalisées',
'afficher_les_plugins_incompatibles' => 'Afficher les plugins incompatibles',
'alerte_compatibilite' => 'Compatibilité forcée',
'alerte_compatibilite_version_autorisee' => 'Les plugins compatibles avec SPIP <code>@version@</code> peuvent être activés.',
// B
'bouton_activer' => 'Activer',

2
paquet.xml

@ -1,7 +1,7 @@
<paquet
prefix="svp"
categorie="maintenance"
version="1.1.7"
version="1.1.8"
etat="stable"
compatibilite="[3.2.0-dev;]"
logo="svp-64.png"

Loading…
Cancel
Save